ReachMee - Performance issues

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 14:53 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 13:23 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 19, 2025 - 13:21 CET

Identified

We are experiencing some issues with ReachMee that seems to apply to most of our customers. Technician is on it and will implement a fix as soon as possible.
Posted Mar 19, 2025 - 13:11 CET
This incident affected: ReachMee.