Candidates not showing inside projects
Incident Report for Talentech
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 08:57 CEST
Investigating
Several customers are reporting that they are not able to find their candidates in certain recruitmentprojects. We are working to identify the problem and fix it as soon as possible.
Posted Apr 22, 2024 - 15:22 CEST
This incident affected: ReachMee.