Talent Recruiter - Issues with Jobnet media
Incident Report for Talentech
Resolved
This incident has now been resolved.
Posted Nov 12, 2024 - 10:00 CET
Investigating
We are currently experiencing an issue with Jobnet where the form is not complete. We will fix this as soon as possible.
Posted Nov 12, 2024 - 09:35 CET
This incident affected: Talent Recruiter.