Issues with creating new users in Talent Recruiter
Incident Report for Talentech
Resolved
This issue has now been resolved.

In case any users experience issues with logging into Talent Recruiter, please contact your local admin and request them to update/save your user profile and the issue will be fixed automatically.

Otherwise feel free to contact your local support team and we will be ready to help you!

We apologize for the inconvenience.
Posted Nov 23, 2022 - 19:24 CET
Investigating
We are currently experiencing issues with creating new users in Talent Recruiter. The system prompts an error, but afterwards saves the user locally to the system. No Talentech ID is connected to the user and therefore the user is not editable and cannot login.

We are working fast to find a solution ASAP and will keep you updated.
Posted Nov 23, 2022 - 17:30 CET
This incident affected: Talent Recruiter.