Some candidates are currently having connectivity issues with accessing vacancies list, whilst application forms are also not available to access.

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 17:55 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 03, 2025 - 16:18 CET

Update

The error has been identified and addressed by our technical team, who are working with the highest priority.
Posted Nov 03, 2025 - 16:04 CET

Investigating

We are investigating and looking into the issue.
Posted Nov 03, 2025 - 14:15 CET
This incident affected: Talent Recruiter.