Ongoing connectivity issues in Talent Recruiter

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 14:24 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 12, 2025 - 10:55 CET

Investigating

We are currently experiencing connectivity issues that are impacting some of our services.
This is affecting candidates’ access to application forms and user login to Talent Recruiter, and some users may also experience difficulties navigating within Talent Recruiter.
Also viewing of the joblist can be affected.
We will provide further updates as soon as more information becomes available.
Posted Dec 12, 2025 - 09:10 CET
This incident affected: Talent Recruiter.