Issues with digital signature

Incident Report for Talentech

Update

An interim workaround has been implemented and is currently handling requests. A permanent fix is in progress, please note that the workaround is not fully stable.
Posted Apr 18, 2026 - 07:12 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 20:36 CEST

Investigating

We are currently investigating an issue related to digital signature, where documents are not being sent and remain in a queue status.
Posted Apr 17, 2026 - 14:46 CEST
This incident affects: Talent Manager and Talent Recruiter.