Some customers may experience errors when downloading form results from the boardee's profile.

Incident Report for Talentech

Resolved

The issue has been resolved, and forms submitted are now available for download.

Thanks for your patience.
Posted Nov 14, 2025 - 17:34 CET

Update

We are continuing to work on a fix for this issue with the highest priority. We apologize for the inconvenience this is causing. Thanks for your patience.
Posted Nov 12, 2025 - 13:41 CET

Identified

In some apps is not possible to download form results submitted by boardees. The error has been identified and addressed by our technical team, who are working with the highest priority.
Posted Nov 05, 2025 - 12:05 CET
This incident affected: Talmundo.