Issues with invitation to interview

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 16:30 CEST

Investigating

We are currently investigating an issue related to inviting candidates to interviews, where it is not possible to send invitations.
Posted Apr 20, 2026 - 13:40 CEST
This incident affected: Talent Recruiter.