DK SUPPORT PHONE ISSUES
Incident Report for Talentech
Resolved
The phone provider has now fixed their issues and we are available on the phone again.
Posted Dec 20, 2023 - 16:28 CET
Investigating
Our danish phone provider is currently experiencing issues making it impossible to call the danish support. They are working to fix it as soon as possible. Please write us through our form for support: www.talentech.dk/kontakt
Posted Dec 20, 2023 - 12:29 CET
This incident affected: irecommend, Ontame, People Core, Talent Manager, Talent Recruiter, Talentech ID, Talmundo, ReachMee, Webcruiter, Weekli and APIs (Evaluation API).