Issues with logging in to Talent Recruiter

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 13:55 CEST

Update

We are continuing to investigate this issue.
Posted Apr 11, 2025 - 13:30 CEST

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 13:29 CEST
This incident affected: Talent Recruiter.