Talent Recruiter and Talent Manager is currently unavailable
Incident Report for Talentech
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 15:59 CET
Investigating
We are investigating an issue with accessing Talent Recruiter and Talent Manager. We are working on a solution to resolve this as fast as possible.
Posted Nov 18, 2021 - 15:53 CET
This incident affected: Talent Manager and Talent Recruiter.