Talent Recruiter and Talent Manager - System slowness
Incident Report for Talentech
Resolved
The issue with our server provider has now been resolved.
Posted Oct 16, 2024 - 15:35 CEST
Investigating
We are currently investigating slowness in Talent Recruiter and Talent Manager for some customers. We will update this status as soon as possible.
Posted Oct 16, 2024 - 15:06 CEST
This incident affected: Talent Manager and Talent Recruiter.