Issues with reference checks

Incident Report for Talentech

Resolved

The issue has been resolved and the fix is in production!
Posted May 23, 2025 - 15:47 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 15:40 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 23, 2025 - 14:50 CEST

Investigating

There's currently an issue sending reference checks through ReachMee, we're currently investigating what's causing it.
Posted May 23, 2025 - 14:17 CEST
This incident affected: ReachMee.